Proxmox VM Zigbee Volkszähler USB FT232 Serial

ttyUSB0 in Proxmox VM mit Debian 10.5.

Ich habe ioBroker wieder in eine VM installiert weil es für mich einfacher ist die USB Geräte durchzureichen. Mit ioBroker im CT, hatte ich des öfteren Probleme, wenn ich den Host neu gestartet habe, die USB Adapter eine andere Device ID bekommen haben. Somit musste ich des öfteren händisch die config von dem CT anpassen.

Nun zum eigentlichen....

Ich habe also eine VM aufgesetzt, alle USB Geräte für ioBroker hinzugefügt und musste feststellen, dass der Adapter Zigbee mit dem Gerät ttyACM0 nur funktioniert, wenn ich die Einstellungen speichere. Beim Smartmeter Adapter hatte er den ttyUSB0 gar nicht erst gefunden.

Bei lsusb sah es so aus:

root@iobroker:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 0764:0601 Cyber Power System, Inc. PR1500LCDRT2U UPS
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 005: ID 0451:16c8 Texas Instruments, Inc. 
Bus 003 Device 004: ID 0403:6001 Future Technology Devices International, Ltd FT232 Serial (UART) IC
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 0627:0001 Adomax Technology Co., Ltd 
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Trotzdem wurden kein ttyUSB0 eingerichtet.

Dann habe ich mal unter dmsg geschaut und gesehen das der ttyUSB0 eingerichtet wird, aber kurz danach wieder getrennt wird. Hatte erst gedacht das es an verschiedenen rechten usw. liegt aber das Problem konnte ich nicht lösen. Google sagte dann das hier:

https://forum.ubuntuusers.de/topic/problem-mit-usb-seriell-wandler-geloest/

also in die Konsole

apt-get remove brltty

eingegeben und die VM neu gestartet.

Infos zu brltty: https://packages.debian.org/de/sid/brltty

Danach lief alles ohne Probleme. Bei Zigbee musste nichts mehr eingestellt werden und auch der Smartmeter Adapter hat sein ttyUSB0 sofort erkannt und Daten geliefert.

Habe mir gedacht ich teile diese Information gern mit euch. Denn das Forum hat mir schon des öfteren weiter geholfen und falls andere mal vor dem Problem stehen, haben sie hier die Lösung und wiederum andere die danach Googlen, werden im ioBroker Forum fündig.

Vorheriger Beitrag